Bug #139

lighttpd not taking requests

Added by mjl almost 9 years ago. Updated about 1 year ago.

Status:Closed Start date:
Priority:Normal Due date:12/31/1969
Assignee:cecil % Done:

0%

Category:- Spent time: -
Target version:6.02.00

Description

I can ping the box however it won't cough up a web page. I see content in /data/srv/httpd/htdocs/ Once I set the document root in /etc/lighttpd/lighttpd.conf it gives the home index R5.5 page. Trying for mythweb give a 403 permissions error. Some of the other pages work.

History

Updated by cecil almost 9 years ago

Try the following:
sudo pacman -Sy
sudo pacman -S lighttpd
cd /etc/lighttpd/
ls

Do you see multiple .confs? If so, copy the latest version as lighttpd.conf.
sudo sv restart lighttpd

Updated by mjl almost 9 years ago

403 - Forbidden

ls /etc/lighttpd/

lighttpd.conf

sudo sv restart lighttpd

ok: run: lighttpd: (pid 5817) 1s

Still get: 403 - Forbidden :(

Still have troubles with lf & cr in flyspray too.

Updated by cecil almost 9 years ago

Did you upgrade lighttpd?

Updated by mjl almost 9 years ago

sudo pacman -Sy

sudo pacman -S lighttpd

cd /etc/lighttpd/

ls

I thought I did but will re-run tomorrow night. It appeared to have gone through the steps but the lf/cr makes things appear differently in the comment section than when they were in the posted section. Does not Flyspray like Iceweasle?

Also only had one .conf file
Mike

Updated by mjl almost 9 years ago

Sorry, Thought I had replied but guess it didn't stick to the flypaper..

Yes, I did a repeat to doing the upgrade of the web server but I don't recall the messages. Now when I try, Iam getting an error of "not found in sync db"

Mike

Updated by robloxaz about 1 year ago

Thanks for the best blog.it was very useful for me. keep sharing such ideas in the future as well. this was actually what i was looking for,and i am glad to came here! roblox, mortal kombat x, a10.com

Also available in: Atom PDF